Geographic Coordinate System

- **Latitudes** (Y axis) change from south to north
- **Longitudes** (X axis) change from east to west

**Parallels** (lines of equal latitudes, parallel to equator)

**Meridians** (lines of equal longitudes, parallel to Prime meridian)

**Example of coordinate system definition:**

- **Units:** degree
- **Name:** WGS84
- **Datum:** WGS84

**Units**: decimal degree (1 degree on equator = 111.32 km; 45 deg latitude = 78.85 km); Units define precision of your GIS data. For example, loss of one decimal in decimal degree will result in 10-12 km error, three digits – 111 m. So, keep minimum number at 5 or 6 to be within 1 or less meters.

**Spatial structure**: Longitudes and latitudes; Earth radius (semimajor: 6,378,137 m; semiminor: 6,356,752.3 m); Prime meridian: Greenwich

**Main parameters** you need to know of any coordinate system: Name of coordinate system; Units; Horizontal/Vertical Datum
Geographic Space in GIS:

Sphere (unprojected)

Euclidian/Cartesian Space (projected)

Projections are needed to calculate areas and distances with certain accuracy

Since computers are based on binary system, GIS can not use Deg. Min. Sec.; it uses decimal degree
Geographic Projections:

Graticule on sphere

0 (Greenwich meridian)

Projected graticule

All units are DECIMAL DEGREES, e.g. -74.57462, 45.493826
Geographic Projections:

Transformation of globe to flat surface **cannot** preserve all properties of the original sphere.

Some of these sphere properties are:

1. All meridians converge at poles
2. Parallels decrease in length toward the poles
3. The scale of the surface of the globe is the same in all directions

During projection process these three properties are distorted.
Geographic Projections:

**Conformal**: preserves **angles** and **shapes**;

**Equivalent** (or **Equal Area**): preserves **areas**

**Equidistant**: preserves **distances**

**Azimuthal**: preserves **directions**

Conformal and Equivalent are mutually exclusive and represent global properties (i.e. apply to the entire map projection)

Equidistant and Azimuthal represent local properties (i.e. apply to the center of projection)
Geographic Datums:

Datum is mathematical model of the Earth which serves as the reference or base for calculating the geographic coordinates of a location.

Uses: semimajor (equatorial) and semiminor (polar) radius measures; flattening ratio.

Datum examples:
Clarke 1866
NAD27 (North American datum 1927)
NAD83 (North American datum 1983)
GRS80 (Geodetic Reference System 1980)
WGS4 (World Geodetic System 1984)
Things to remember (really, I mean it) and understand:

1. **Geographic coordinate system** is based on a datum. It includes datum definition as a part of spatial reference. Always know your datum! Most typical one is **WGS84**, especially if you use geographic coordinate system as your spatial reference.

2. **Geographic projection** is based on coordinate system and datum. **It includes coordinate system and datum** as a part of its spatial reference structure.

3. **Both, geographic coordinate systems and projections** are generally referred in GIS as a “spatial reference.”

4. Spatial reference of GIS raster data (grids, images) can be accessed by right-click on data (in ArcMap or ArcCatalog) → Properties → Source (Tab).

5. Spatial reference of GIS vector data (shapefiles) can be accessed through:
   a) .PRJ files (shapefile structure) or .TFW, JPW (images); file can be either present or not;
   b) View shapefile spatial reference right-click in ArcMap TOC (or in ArcCatalog) → Properties → Source (Tab).

6. Spatial reference of your ArcGIS project can be viewed through ArcMap View properties:
   ArcMap → View → Data Frame Properties → Coordinate System (Tab)
Universal Transverse Mercator (UTM)

One of the most commonly used for few hundred kilometers segments
Universal Transverse Mercator (UTM) Structure:

Units: meters or feet;

Spatial structure: 60 zones, each = 6 degree of longitude (~674,000 m).

Main parameters you need to know:

1. Zone number and orientation (north or south, i.e. 18N or 18S);
2. Units (meters or feet); X – easting; Y - northing
3. Datum (e.g. NAD27, NAD83, NAD84 or WGS84)
   where NAD – North American Datum.
   WGS – World Geodetic System

Accuracy: meter/sub-meter

Example for New York:
Unites: meters;
Zone: 18 North or 18N;
X: 587420 (distance from the beginning of the zone, i.e. 587 km east);
Y: 4517571 (distance from equator, i.e. 4,518 km north) ;
Datum: NAD27
Universal Transverse Mercator (UTM) Structure:

An example of one zone with both, geographical coordinate system and UTM.
The State Plane Coordinate System (SPCS) is a system that uses plane rectangular coordinates. It was developed in the 1930s by the U.S. Coast and Geodetic Survey to provide a common reference system to surveyors and mappers. This coordinate system divides all fifty states of the United States, Puerto Rico and the U.S. Virgin Islands into over 120 numbered sections, referred to as zones (or FIPS, Federal Information Processing Standard). In the SPCS, each state has its own zone(s). Each zone has an assigned code number that defines the projection parameters for the region. The SPCS does not work across states.

One of the most commonly used for local surveys and engineering applications
State Plane Coordinate System (SPCS)

**Units:** feet (in general) and meters (less common);

**Spatial structure:** over 120 zones in US; Each **zone** or **FIPS** has its own central meridian or standard parallels to maintain accuracy. States that are elongate from north to south, such as California, use a Lambert conformal conical projection. States that are elongate from east to west, such as New York, use a transverse Mercator projection. This is done to minimize the distortion within each zone.

**Main parameters** you need to know:

1. Zone number: 3102 (New York Central) or 3101 (New York East).
2. Units (meters or feet);
3. Datum (e.g. NAD27 or NAD83), where NAD – North American Datum.

Accuracy: meter/sub-meter/sub-foot

**Example for New York:**
Units: feet;
Zone: 3102, New York Central;
X: 750675  (distance from the western beginning of the zone);
Y: 555107  (distance from southern beginning of the zone);
Datum: NAD83;
Difference in coordinate system/projection units OR “Why sometimes we do not see our data in ArcMap when spatial reference is absent or wrong?”:

An example for New York City:

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>590641</td>
<td>4517333</td>
</tr>
<tr>
<td>1235867</td>
<td>303312</td>
</tr>
</tbody>
</table>

Geographic Coordinates: degrees, min, sec:
-73° 55’ 31”  40°48’ 07”

decimal degrees:
-73.92 40.80

UTM, NAD27, zone 18N, meters:

SPC, New York Central, feet:

It is useful to know latitude (Y) and longitude (X) ranges of various spatial reference’ values to be able to “guess” unknown coordinate system/projection. This comes by working with variety of data in different spatial reference systems.
General Hints on spatial reference in New York area:

<table>
<thead>
<tr>
<th>Longitude</th>
<th>Latitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>-73° 55’ 31”</td>
<td>40°48’ 07”</td>
</tr>
<tr>
<td>-73.92</td>
<td>40.80</td>
</tr>
</tbody>
</table>

For this spatial reference the max number of digits in longitude will be always 3, i.e. 180 (eastern or western hemisphere). The max latitude will be always 2 digits (southern or eastern hemisphere).

UTM, NAD27, zone 18N, meters: 590641  4517333
For this spatial reference of New York state the maximum number of digits will be always 6 in longitude and 7 in latitude (distance in meters from equator)

SPC, New York Central, feet: 1235867  303312
This spatial reference will generally have up to 7 digits in longitude and 6 digits in latitude
Difference in spatial reference units:

Why the same place in different spatial reference system is not in the same location?

New York City – one place – three different locations

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>-73.92</td>
<td>40.8</td>
</tr>
<tr>
<td>590641</td>
<td>4517333</td>
</tr>
<tr>
<td>1235867</td>
<td>303312</td>
</tr>
</tbody>
</table>

An abstract Coordinate System
Difference in spatial reference units:

How ArcGIS reconciles differences in spatial reference of various GIS data?
Difference in spatial reference units:

How ArcGIS reconciles differences in spatial reference of various GIS data?

The first layer with corresponding .prj file added to TOC defines the Data Frame’s coordinate system. For example, if the first layer added contains a UTM system, all other layers will re-project on the fly to match it regardless of their spatial reference. If .prj file is absent, then ArcMap will issue a warning message that spatial reference is missing.

Similarly, if the first layer added to the TOC contains data that uses a WGS84 geographic coordinate system, all other layers will be adjusted by software to match this. Even data with UTM will be re-projected on the fly, but not permanently, only for visualization.

Questions to consider:

1. What will happen if I will add a second dataset without .prj file?
2. What will happen if the first added dataset does not have .prj file?
3. What will happen if your .prj file is wrong?
Coordinate System / Projection Issues in ArcGIS

TWO CHECK POINTS FOR THE SUCCESSFUL “PROJECTION ON A FLY”

1. View → Data Frame Properties:
   • “Coordinate System” tab cannot have Coordinate system as “No coordinate system”!!!
   • “General” tab cannot have “Unknown Units” for Map

2. Layer → right-click → Properties → Source:
   • Cannot have Coordinate System as “Undefined”
   • Cannot have question marks (?) next to coordinate values in “Extent” box

Tip of the Day:
.PROJ (PROJECTION) FILE SHOULD EXIST FOR EVERY SHAPEFILE!!!!!!!!!!!!!!!

If projection file does not exist, you can create it (use Define Projection tool in ArcToolBox) if you know spatial reference or can just guess it.

For example, values like -70.345, 34.2391, etc. will be possibly decimal degree units of the Geographic Coordinate System. Any kind of values like 346756.2 or 1654346 are large and will be either meters or feet, i.e. UTM or State Plane Projected Coordinate System

After creating .prj file check View → Data Frame Properties and make sure that your spatial reference is defined as well (especially if the shapefile without .prj was added to the TOC first) You can also use option Import and use your newly updated shapefile to set a spatial reference in Data Frame.
More on map projections:

ESRI documentation:

http://resources.esri.com/help/9.3/arcgisengine/dotnet/89b720a5-7339-44b0-8b58-0f5bf2843393.htm

Peter Dana, Colorado State University
(the most comprehensive, can be overwhelming):

http://www.colorado.edu/geography/gcraft/notes/mapproj/mapproj_f.html
Map Units. Information for this window comes from .prj file; if .prj file is absent, then software will issue a warning error and set units as “Unknown”.

Display Units. Software will use Map Units to convert them into user defined units for display purposes only.
Data Frame Properties

- In Data Frame Properties tab Coordinate System sets a coordinate system for the whole ArcMap project and NOT for individual layers.

- Map units: horizontal measures in which distances are calculated in a data frame – Feet, meters, etc.

- Display units: horizontal measures in which distances are actually displayed on the screen – Feet, meters, etc.

Use Import option if you already have shapefile with .prj file.
Data Frame Properties (cont.)

• Map units are set when a coordinate system is specified for a data frame.

The settings for Coordinate System come from .prj file from the very first shapefile. If you add a first shapefile without .prj component, then Data Frame Properties will have “Unknown units” for Map.
• **On-the-fly** projection requires spatial reference definition:
  – For shapefiles: stored in `.prj` file
  – For images: stored in the header of image file or in a separate file (e.g. `.jpgw`, `.tifw`, etc.)

Unknown Spatial Reference Warning:

This happens when shapefile does not have `.prj` file

*This is a warning, not error message* so you can proceed and view layer but **you will not be able** to experience “on-the-fly” capability of ArcMap.
Layer Properties

Layer -> Properties -> Source

Layer Properties tab Source shows a coordinate system for individual layer.

If you cannot see all attributes of the coordinate system definition, then your layer has no defined projection. In the case of shapefiles this means that you do not have a .prj file.

In this specific example the solution is following:

1. Guess what projection is: ????
2. Use Define tool to create .prj file
Layer Properties

Layer → Properties → Source

Layer Properties tab Source shows a coordinate system for individual layer.

If you can see coordinate system for the Layer with all necessary attributes of coordinate system definition then your layer has a defined projection. In the case of shapefiles this information is stored in .prj file or within the header of the image or GRID.

Known Spatial Reference in ArcMap:
Layer Properties (raster data)

If data misses spatial reference you can check it via Layer Properties → Source

In this example, the dataset that misses spatial reference is raster image.

Notice extension .tif
Layer Properties: spatial reference

What does this mean to you?

1. **If you produce a map, no problem:** The software will automatically “re-project on the fly” your data and all layers will match.

2. **If you intend to do spatial analysis using “overlay” functions or any other function that requires calculations between two geographic datasets,** you might want to consider using Project tool to change coordinate system/projection to **one uniform type** because certain analytical functions in ArcMap ToolBox might not work correctly with multiple spatial references and produce error messages.
Adding spatial reference info to raster dataset (image, GRID)

ArcCatalog: right-click on dataset and select Raster Dataset Properties → Edit button
Adding spatial reference to shapefiles (creating .prj file)
Use when data projection is known but not explicitly defined. Some GIS functions will not work unless you have projection explicitly defined. For shapefiles this option will create .prj file.

Use to change projection (i.e. re-project from one projection to another (like converting units))

Do Not Mix These Tools !!!!
Projection (Datum) Change in ArcMap:

This tool is used only if your spatial references are defined in both datasets
How to create .prj file (or change one) in ArcMap:

This tool is used only if your spatial reference is not defined (i.e. .prj file is absent) or existing .prj file is incorrect. It can be also used for raster data.
How to create .prj file (or change one) in ArcMap:
How to create .prj file (or change one) in ArcMap:

1. Open ArcMap.
2. Go to the ‘File’ menu and select ‘Properties’.
4. Click on the ‘Coordinate System’ drop-down menu and select ‘Browse for Coordinate System’.
5. In the ‘Browse for Coordinate System’ window, select the coordinate system you want to use.
6. Click on ‘Add’ to add the selected coordinate system.
7. Click on ‘OK’ to close the window and apply the changes.

This process will create or change the .prj file in ArcMap.
Georeferencing Raster Data & Images Using Affine Transformation

Customize → Toolbar → Georeferencing

Establishing control points:

1, 2, 3, and 4 are points with known coordinate (i.e. measured) pairs X, Y.

Source units (for example, they can be units of scanning device, like 11 x 18, etc.)
Georeferencing of digital images:

Assigning coordinate system to hard copy (e.g. standard map) or digital media (e.g. satellite image); For digital images this process creates so-called “world file” or writes information in the image itself (e.g. GeoTIFF)

Points for georeferencing come from:
1. GPS measurements
2. Another map or digital source (e.g. Google Earth); GIS data with known coordinate system;

TIC mark that can be used for georeferencing/registration

Reference Table

<table>
<thead>
<tr>
<th>X, Y Map (measured)</th>
<th>X,Y Computer Screen/Media</th>
</tr>
</thead>
<tbody>
<tr>
<td>-75.43287, 43.8751</td>
<td>0.9, 0.8</td>
</tr>
<tr>
<td>-75.43459, 43.8231</td>
<td>0.01, 0.1</td>
</tr>
<tr>
<td>........</td>
<td>........</td>
</tr>
</tbody>
</table>
1. Establish control points and their real-world coordinates;
2. Run transformation on control points and apply transformation to map features (Rectify).

X, Y of control points in scanned/or other source (image) units

X, Y of control points in desired coordinate units (usually measured in the field or derived from other data)

Rectification
gereferenced

original image
Georeferencing Raster Data & Images

Root mean square error (RMS) – measures deviation between original and georeferenced (estimated) locations. 

$$\text{RMS} = \sqrt{(X_1-X_2)^2 + (Y_1-Y_2)^2}$$
Transformation Process: Bilinear Interpolation

Considers closest 2x2 neighborhood of pixels with known values surrounding pixel with unknown value. Then it takes weighted averages of four known values in two directions (i.e. bi-linear).

\[ a = (0.8 \times 5) + (0.2 \times 10) = 6 \]
\[ b = (0.8 \times 10) + (0.2 \times 15) = 11 \]
\[ x = (0.4 \times 6) + (0.6 \times 11) = 9 \]

Red color – grid (pixel) values
Blue color – coordinate system values
More on Georeferencing: